Monday 23 August 2010

Modifications to my underlying Lab Config

I have patched up my home lab to resemble the IPExpert topology - it's not a 100% mapping due to the switches I'm using (3750s interfaces are named FastEthernet1/0/1 rather than FastEthernet0/1 to accomodate the stacking capability) and that I am using simulated 7200s which will have slightly different serial interface numbers (for some reason when I use 3700s I cannot see the switches via CDP but its fine with a 7200) so I will rely on some sed based scripts that will rework the configs to suit the environment.

The main change to my logical configuration is that rather than using the ethernet switch within dynamips to provide dot1qtunnelling with the usual Mr Paul Configuration I have taken the concept from 21500 where the outer VLANs are directly defined on the linux system with dynamips router interfaces terminating directly onto the linux VLAN interfaces.

The reason I did this was that this way I could actually run virtual hosts on my linux box and terminate them onto local VLAN interfaces that can drop out of my breakout switch (With the 3 virtual hosts, I am now using 24 fastethernet ports on my 3550 breakout switch)

On My Ubunutu Box
eth1 is the management interface on my home lan
eth0 is the interface facing CatB (The breakout switch)

to /etc/modules I added the line "8021q" which then enabled native 802.1q support

"sudo apt-get install bridge-utils" to install the bridging utilities so we can create bridge interfaces (much like a BVI on a cisco router)


In the interface configuration definition below, the interfaces I want to use (eth0.x) are enabled via pre-up vconfig add statements in order for the vlans to go operational when the main interface comes up.  Since we haven't applied an IP config on eth0, we need a cheat to bring the interface up automatically (done with pre-up ifconfig eth0 up)

The management IP interface is br0 which is attached to eth1.  It was done this way so devices that use TAP interfaces can be added as ports attached to bridge br0 for internet access if they need it.


start of /etc/network/interfaces

# The loopback network interface
auto lo
iface lo inet loopback

# CatB Facing Interface
auto eth0
iface eth0 inet manual
        # Set the vlan naming to be interface.vlanid
        pre-up vconfig set_name_type DEV_PLUS_VID_NO_PAD
        vlan-raw-device eth0
        pre-up vconfig add eth0 101
        pre-up vconfig add eth0 102
        pre-up vconfig add eth0 201
        pre-up vconfig add eth0 202
        pre-up vconfig add eth0 203
        pre-up vconfig add eth0 401
        pre-up vconfig add eth0 402
        pre-up vconfig add eth0 501
        pre-up vconfig add eth0 502
        pre-up vconfig add eth0 601
        pre-up vconfig add eth0 602
        pre-up vconfig add eth0 701
        pre-up vconfig add eth0 702
        pre-up vconfig add eth0 801
        pre-up vconfig add eth0 802
        pre-up vconfig add eth0 901
        pre-up vconfig add eth0 902
        pre-up vconfig add eth0 11
        pre-up vconfig add eth0 22
        pre-up vconfig add eth0 33
        pre-up ifconfig eth0 up
        post-down vconfig rem eth0.101
        post-down vconfig rem eth0.102
        post-down vconfig rem eth0.201
        post-down vconfig rem eth0.202
        post-down vconfig rem eth0.203
        post-down vconfig rem eth0.401
        post-down vconfig rem eth0.402
        post-down vconfig rem eth0.501
        post-down vconfig rem eth0.502
        post-down vconfig rem eth0.601
        post-down vconfig rem eth0.602
        post-down vconfig rem eth0.701
        post-down vconfig rem eth0.702
        post-down vconfig rem eth0.801
        post-down vconfig rem eth0.802
        post-down vconfig rem eth0.901
        post-down vconfig rem eth0.902
        post-down vconfig rem eth0.11
        post-down vconfig rem eth0.22
        post-down vconfig rem eth0.33
        mtu 1540

# The primary network interface
auto eth1
iface eth1 inet manual
        pre-up ifconfig eth1 up

#server management/internet access
auto br0
iface br0 inet static
        address 192.168.1.248
        netmask 255.255.255.0
        broadcast 129.168.1.255
        gateway 192.168.1.254
        bridge_ports eth1
        bridge_maxwait 0
        bridge_fd 0
        bridge_stp off

end of /etc/network/interfaces

CatB will make use of the VLANs defined above to split out to feed to Cat1, Cat2, Cat3 and Cat4 as well as VLANs 97, 98 and 99 which will be created on demand for extra hosts.

start of CatB Config

hostname CatB-3550
aaa new-model
aaa authentication login default none
aaa authentication enable default none
aaa authorization exec default none
vtp mode transparent
vlan 11,22,33,97-99,101-102,201-203,401-402,501-502,601-602,701-702,801-802
vlan 901-902
interface FastEthernet0/1
 description R1 Fa0/0 to Cat1 Fa1/0/1
 switchport access vlan 101
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/2
 description R1 Fa0/1 to Cat2 Fa1/0/1
 switchport access vlan 102
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/3
 description R2 Fa0/0 (Gi0/0 RJ45) to Cat1 Fa1/0/2
 switchport access vlan 201
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/4
 description R2 Fa1/0 (Gi0/0 SFP) to Cat1 Fa1/0/12 (Gi0/2)
 switchport access vlan 202
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/5
 description R2 Fa0/1 (Gi0/1 RJ45) to Cat2 Fa1/0/2
 switchport access vlan 203
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/6
 description R4 Fa0/0 to Cat1 Fa1/0/4
 switchport access vlan 401
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/7
 description R4 Fa0/1 to Cat3 Fa0/4
 switchport access vlan 402
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/8
 description R5 Fa0/0 to Cat1 Fa1/0/5
 switchport access vlan 501
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/9
 description R5 Fa0/1 to Cat3 Fa0/5
 switchport access vlan 502
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/10
 description R6 Fa0/0 to Cat2 Fa1/0/6
 switchport access vlan 601
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/11
 description R6 Fa0/1 to Cat4 Fa0/6
 switchport access vlan 602
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/12
 description R7 Fa0/0 to Cat 2 Fa1/0/7
 switchport access vlan 701
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/13
 description R7 Fa0/1 to Cat4 Fa0/7
 switchport access vlan 702
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/14
 description R8 Fa0/0 to Cat 2 Fa1/0/8
 switchport access vlan 801
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/15
 description R8 Fa0/1 to Cat 4 Fa0/8
 switchport access vlan 802
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/16
 description R9 Fa0/0 to Cat2 Fa1/0/9
 switchport access vlan 901
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/17
 description R9 Fa0/1 to Cat4 Fa0/9
 switchport access vlan 902
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/18
 description BB1 Fa0/0 to Cat1 Fa1/0/11
 switchport access vlan 11
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/19
 description BB2 Fa0/0 to Cat2 Fa0/12
 switchport access vlan 22
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/20
 description BB3 Fa0/0 to Cat2 Fa1/0/13
 switchport access vlan 33
 switchport mode dot1q-tunnel
 l2protocol-tunnel cdp
 no cdp enable
 spanning-tree portfast trunk
!
interface FastEthernet0/21
 description Host1 eth0 to Cat2 Fa1/0/15
 switchport access vlan 97
 switchport mode access
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/22
 description Host2 eth0 to Cat2 Fa1/0/16
 switchport access vlan 98
 switchport mode access
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/23
 description NMS eth0 to Cat2 Fa0/14
 switchport access vlan 99 
 switchport mode access 
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/24
 description To Router Simulator Trunk
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 11,22,33,97-99,101,102,201-203,401,402,501,502
 switchport trunk allowed vlan add 601,602,701,702,801,802,901,902
 switchport mode trunk
 l2protocol-tunnel cdp
 spanning-tree portfast trunk

End of CatB Config
 
To give an example as to how one of the virtual hosts on my routersim would be called into existence. I have a qemu virtual pc setup and ready to go.

I invoke it by typing:
sudo qemu nms.img -m 64 -curses -net nic,macaddr=00:aa:00:60:01:01 -net tap,ifname=tap99,script=/etc/qemu-ifup-nms


eth0 will be attached to the interface tap99 - when we call the script /etc/qemu-ifup-nms it will create the bridge br99 which will have tap99 and eth0.99 as member ports which will allow the NMS to be presented via CatB Fa0/23

 
Start of /etc/qemu-ifup-nms
#!/bin/sh
sudo /sbin/vconfig add eth0 99
sudo /usr/sbin/brctl addbr br99
sudo /usr/sbin/brctl addif br99 eth0.99
sudo /usr/sbin/brctl stp br99 off
sudo /sbin/ifconfig eth0.99 up
sudo /usr/sbin/brctl addif br99 $1
sudo /sbin/ifconfig $1 up
sudo /sbin/ifconfig br99 up
sleep 2
End of /etc/qemu-ifup-nms

Similar configurations are set up for Host1 (tap97, br97, eth0.97 - CatB Fa0/21) and Host2 (tap98, br98, eth0.98 - CatB Fa0/22)

Below is my current incarnation of the IPExpert topology. Rather than using the internal Frame Switch, I have set up a router to act in that role.

Start of ipexpert.net
autostart = false
ghostios = true

[localhost]
        workingdir = /home/adam/cisco/work_ipexpert
        [[7200]]
                image = /opt/ios/unzipped/c7200-adventerprisek9-mz.124-24.T.bin
                npe = npe-225
                ram = 160
                idlepc = 0x6307ad74
                disk0 = 128

        [[2611]]
                image = /opt/ios/unzipped/c2600-js-mz.123-17a.bin
                ram = 64
                idlepc = 0x803266c4
        [[3725]]
                image = /opt/ios/unzipped/c3725-advsecurityk9-mz.124-15.T12.bin
                ram = 128
                disk0 = 64
                idlepc = 0x60bb28d0

        [[ROUTER R1]]
                model = 7200
                console = 2001
                slot0 = PA-C7200-IO-2FE
                f0/0 = NIO_gen_eth:eth0.101
                f0/1 = NIO_gen_eth:eth0.102

        [[ROUTER R2]]
                model = 7200
                console = 2002
                slot0 = PA-C7200-IO-2FE
                slot2 = PA-4T
                f0/0 = NIO_gen_eth:eth0.201
                f0/1 = NIO_gen_eth:eth0.203
                f1/0 = NIO_gen_eth:eth0.202
                s2/1 = FR s0/0
                s2/2 = R5 s2/2

        [[ROUTER R4]]
                model = 7200
                console = 2004
                slot0 = PA-C7200-IO-2FE
                slot2 = PA-4T
                f0/0 = NIO_gen_eth:eth0.401
                f0/1 = NIO_gen_eth:eth0.402
                s2/0 = FR s0/1

        [[ROUTER R5]]
                model = 7200
                console = 2005
                slot0 = PA-C7200-IO-2FE
                slot2 = PA-4T
                f0/0 = NIO_gen_eth:eth0.501
                f0/1 = NIO_gen_eth:eth0.502
                s2/1 = FR s0/2

        [[ROUTER R6]]
                model = 7200
                console = 2006
                slot0 = PA-C7200-IO-2FE
                slot2 = PA-4T
                f0/0 = NIO_gen_eth:eth0.601
                f0/1 = NIO_gen_eth:eth0.602
                s2/1 = FR s0/3
                s2/2 = R9 s2/2
                s2/3 = R9 s2/3

        [[ROUTER R7]]
                model = 7200
                console = 2007
                slot0 = PA-C7200-IO-2FE
                slot2 = PA-4T
                f0/0 = NIO_gen_eth:eth0.701
                f0/1 = NIO_gen_eth:eth0.702
                s2/2 = R8 s2/2

        [[ROUTER R8]]
                model = 7200
                console = 2008
                slot0 = PA-C7200-IO-2FE
                slot2 = PA-4T
                f0/0 = NIO_gen_eth:eth0.801
                f0/1 = NIO_gen_eth:eth0.802

        [[ROUTER R9]]
                model = 7200
                console = 2009
                slot0 = PA-C7200-IO-2FE
                slot2 = PA-4T
                f0/0 = NIO_gen_eth:eth0.901
                f0/1 = NIO_gen_eth:eth0.902

        [[ROUTER BB1]]
                model = 2611
                console = 2101
                e0 = NIO_gen_eth:eth0.11
                e1 = NIO_gen_eth:eth1

        [[ROUTER BB2]]
                model = 2611
                console = 2102
                e0 = NIO_gen_eth:eth0.22

        [[ROUTER BB3]]
                model = 2611
                console = 2103
                e0 = NIO_gen_eth:eth0.33

        [[ROUTER FR]]
                model = 2611
                console = 2104
                WIC0/0 = WIC-2T
                WIC0/1 = WIC-2T

End of ipexpert.net

Initial Review - IPExpert Video on Demand

So I mentioned earlier that I had ordered some workbooks from IPexpert which was part of one of the bundles they were offering.

As the Volume 1 and Volume 3 workbooks arrived before the R&S Video on Demand Course I did quickly flicked through the volume 1 lab workbook and took the opportunity (or excuse) to fiddle around a little and redesign my lab a little to suit (mainly to support virtual hosts into the design which I will write about that in a later post)

Anyhow - the material for this course consists of a single DVD which has 4 relatively long days of material on it simulating I guess what you may get if you were able to travel to an actual bootcamp delivered by Joe Astorino who was an IPExpert student prior to becoming one of their instructors.  Accompanying the DVD (which is a data disk, not a video disk) is a nearly 400 pages of slides as a hard copy of the slides that are presented in the video - with space below to scribble your own notes in and a separate 19 page topology diagram book which is used in the exercises.

So far I have watched all of the Day 1 Material (Focusing briefly on Study techniques before diving deep into Layer 2 technologies) and some of the Day 4 stuff (I jumped to the back because I was interested in hearing Joe's troubleshooting tips and ideas on navigating the "doc cd")

The method of delivery is firstly to discuss the technology concepts with a lecture component - primarily slide based and then to have some configuration exercises that are a basically form a small lab exercising various constraints that utilise the previously discussed topics and techniques.  The examples are actually pretty good in that you see sometimes Joe has (or appears to have) a bit of a mental block on what to do but you see how he resolves the problem (mainly by checking the doc cd) and also once or twice he introduced a couple of errors into his configs but due to his approach of validating things as you go, you can see him isolate where the issue is and correct it - which is actually pretty good in that it is basically a live demonstration on verification and picking up your mistakes without getting flustered.

If I was to directly compare this with the Audio Boot Camp - the VoD would win hands down - that's not to denigrate the audio material at all, the video just has the advantage of having the slide pack but more importantly because there are diagrams and live updates as to what is happening in the CLI, the lab exercises provide that bit of extra clarity that an audio only class cannot provide.  However while standing on packed train during rush hour, it's easier to focus on the audio material that it would be to watch a video (I don't think the video would do well on a small display really, especially for the config sections)

So while I have only viewed about a quarter of the material so far, I cant see any negatives to report and I am pleased with my purchase and again have been learning new concepts particularly on frame-relay and look forward to learning more in the routing protocols, security, qos, multicast, ipv6 and MPLS areas.

My current plan is to go through the VoD in full once before I start on the Volume 1 workbook labs and after each lab revise the topic on the area that seems to cause me dramas.

Thursday 19 August 2010

Learning about tclsh

On groupstudy someone was asking about how to show all of the route-targets associated with the BGP routes.  I have wondered what nice command would do that myself - it's easy enough to get the route-distinguishers (show ip bgp vpnv4 all) and it is possible to find the route-target for individual prefixes (show ip bgp vpnv4 all prefix/length) but no easy way to quickly get a list of all RTs.

Since we know how to do it manually, the obvious way is to script something up.  TCL (Tool Command Language) is a scripting language that is available on IOS platforms.  The most common TCL script for CCIE candidates appears to of the "ping all your routers" variety which is very helpful in quickly validating connectivity.

The get_rt script is fairly simple but took me a little while to get used to how the syntax and string matching capabilities work.  TCL Tutor is a fantastic tutoring application for the language that as well as describing how things work in individual lessons, also has an interpreter built in with example code that you can modify and run directly.

Below is get_rt:
proc get_rt {} {
    set cmdout [exec "sh ip bgp vpnv4 all | include ^\\*"]
    foreach line [split $cmdout "\n"] {
       if [regexp {([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+\/[0-9]+)} $line prefix] {
          puts [exec "sh ip bgp vpnv4 all $prefix \| include BGP\|RT"]
       }
    }
}
What the lines are doing

  1. proc get_rt {} {
      defines the name of the procedure
  2. set cmdout [exec "sh ip bgp vpnv4 all | include ^\\*"]
       is the same as typing "sh ip bgp vpnv4 all | include ^\*" and assigning the output to a variable called cmdout.  The regular expression means we match only lines that start with a * (in other words we're only caring about valid routes)
  3. foreach line [split $cmdout "\n"] {
       we're starting a loop which takes each line of output from cmdout and temporarily assigning that to a variable called line
  4. if [regexp {([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+\/[0-9+)} $line prefix] {
       the regular expression is attempting matching an ip prefix in the form of a.b.c.d/l in the variable line, and if there is a match, the resulting match is placed into a variable called prefix and the following line is executed
  5. puts [exec "sh ip bgp vpnv4 all $prefix \| include BGP\|RT"]
       displays the output of "show ip bgp vpnv4 all a.b.c.d/l | include BGP|RT" to the output
  6. }
       closes the if evaluation on line 4
  7. }
       ends the loop statement and returns for the next line of evaluation from cmdout in line 3 otherwise if all lines have been processed continue down
  8. }
       closes the procedure definition

So how do you apply and execute it?

In this example R1 is set up with some MP-BGP ipv4 routes, so we can actually get some output:

R1#tclsh
R1(tcl)#proc get_rt {} {
+>(tcl)#set cmdout [exec "sh ip bgp vpnv4 all | include ^\\*"]
+>(tcl)#foreach line [split $cmdout "\n"] {
+>(tcl)#if [regexp {([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+\/[0-9]+)} $line prefix] {
+>(tcl)#puts [exec "sh ip bgp vpnv4 all $prefix \| include BGP\|RT"]
+>(tcl)#}
+>(tcl)#}
+>(tcl)#}

R1(tcl)#get_rt
BGP routing table entry for 64512:10:1.2.3.0/24, version 6
      Extended Community: RT:64512:10

BGP routing table entry for 64512:10:4.3.2.0/25, version 7
      Extended Community: RT:64512:10

BGP routing table entry for 64512:20:2.4.0.0/16, version 8
      Extended Community: RT:64512:20

BGP routing table entry for 64512:20:8.6.4.2/32, version 9
      Extended Community: RT:64512:20
R1(tcl)#


So there you go.  Hopefully this can be used as a simple base for various lumping together commands to get something useful.

As a closing note here, depending on the characters you directly want to use in your strings, you need to escape them for TCL itself not think there is a directive made towards it

Saturday 7 August 2010

Initial Review - INE CCIE R&S Audio Boot Camp Week 1

Separate to the main topic of today but related - I just received an email saying that my material from IPExpert is now winging its way to me - something that I'm quite looking forward to receiving - I have pretty much cabled up my home lab in anticipation - just waiting on receiving a couple of copper SFPs to interconnect Cat1 Gi0/1 and Cat2 Gi0/1 and I think it should be ready to rock....

During the week I have been listening to Scott Morris going through the Internet Expert CCIE R&S Audio Bootcamp for week one.  Once you get purchase the materials, access to downloading it is very quick, there are twenty-six sections that cover layer two technologies and IPv4 routing and MPLS.  The files are in m4a form and encoded at 192kbps, which for spoken word except for the brief punctuation between sections with a few seconds of music 80s rock exerpts from bands such as Def Leppard, Queen and AC/DC amongst others is more than adequate.

The duration of each section does vary depending on the topic- from around 20 minutes up to about an hour and a half - subjects such as OSPF have 3 sections and BGP has 5 sections dedicated to them (the overall uncompressed filesize is nearly 1.5GB for the weeks material)

Anyway, the more important thing is how good is it?  Well I haven't listened to it all yet (and I'm sure I will be listening to various aspects multiple times) but I have to say that I quite enjoy Scott Morris' style of delivery- it kind of gives me the impression that he's an old friend that has come over at your place to chat about networking and knows his stuff but isn't talking down at you - he knows you're keen and wants to help you understand the technologies as well as little gotchas that can crop up.  While it appears to be fairly free flowing, there is structure and form in the presentation that builds upon previous sections.

I find the material easy to listen to but it is something that you have to focus your attention on as it is information rich - if you're multitasking, you're going to miss out on a lot of the info first time round.  Not a problem when you're riding home from work on the train with your ipod going but not so good when you're writing documents and having the lectures play in the background.  I do like the portability though in that you can take a lecture around where books/online resources are more of a hassle to drag around.  This material is specifically made as a self-paced learning material and not an audio track ripped off a video.  In some of the cases diagrams are referred to in order to explain topologies but they are usually simple to explain or reference the standard INE topology for you too look at and visual as Scott is talking.

Can this be used as a sole piece of study material? No way and its certainly not pitched that way - this is more focused on consolidating overall technologies and features into one place then you read up more on the doc CD or lab stuff out and possibly use again as a review after that.

Does this material lock you into INE? Beyond the topology diagram, its more than possible for this to be the only piece of INE material in your study materials (at present I'm heading down the path) although I'm sure it does fit within INE's overall study plan. 

This week the Week 2 material has become available on the INE site and I have already ordered and downloaded that material too, it's not as long in duration as week one and it's not recorded by Scott Morris (I think it's Anthony Sequeira by it's not specifically mentioned anywhere) the focus is on IPv6, Multicast, Security and QoS mechanisms.  Particularly the IPv6 and QoS related topics are chopped up into smaller digestible chunks than a single long and drawn out boredom festival which should be good when it comes to reviewing and being able to review key areas there.  I haven't spent much time checking this out yet, so it's probably going to get a minor review of parts later on.

In closing, am I happy with the INE Audio R&S Boot Camp Week 1 material? Yes I am - I have already picked up a couple of tricks to add to my arsenal, I find it easy to listen to and there should be some good repeatability over the course of my study.  Is it value for money? I paid for this material with my own hard earnt cash and while I haven't listened to it all so far - probably around 70% of it but I would say yes, it's amongst the least expensive training material available not including individual books (but even then you need to have a good number in your library anyway) and is of good quality and information density.

If you have already attended a bootcamp or done a video class and have been happy with what you have walked away with - then perhaps this material may be of lesser value to you, however if you are looking for an alternative view on topics I think you will get value as well.

Monday 2 August 2010

Ordered some workbooks!

It's been some time since my last update - about two months!  The Cisco related focus has slowed down hopefully temporarily.  During this time I have been working on beefing my Alcatel-Lucent Service Routing Certification qualification. After completing 4 exams over the last 5 weeks I have the pre-requisites to reach the Network Routing Specialist II certification (just need to sit and pass the lab exam in Melbourne) and need to pass another two exams to be able to reach the Triple Play Routing Professional...  Hopefully I will be able to sit the NRS-2 lab some time this year.

The last few months have been focused on service provider capabilities - in particular I have been having a lot of fun with FreeRADIUS to perform enhanced subscriber management with the service router platform supporting the termination of DHCP and PPPoE residential subscribers and fun with IPv6 and Multicast.  I really like the way the 7750 platform handles these operations compared to how I remember my early experiences with the Cisco 6400 BRAS nearly 10 years ago, or using the Juniper ERX platform 5 years back.  I suppose the advantage of being a little later to the game is that you can learn what went well, what didn't really make sense and to have it fit into a good, coherent view has certainly been taken and extended into newer generation ethernet access technologies while still supporting "legacy" ATM and L2TP services.

Anyway, the main thrust of this blog is my CCIE pursuit, so on with that:

As the post title mentions, couple of days ago I made another investment into achieving CCIE status.  I paid for a workbook and video on demand package from the guys at IP Expert.  At the end of the day, whether I pass the lab or not is going to be down to me alone, however study materials are definitely contributors to getting there.  While evaluating which vendor I thought would work best with my ideas on study, I spent more than a few months on the Online Study List mailing list that is run by IPX looking at the kind of questions people had (related to technology/concepts, non-CCIE lab specific questions and material related clarification/questions), sometimes even answering a few myself and noticing the frequency and type of responses the IPX guys gave as well as the active community on the mailing list.  In the end, it was this that gave me a feeling that there is a good support there and other students in general appear to enjoy the materials.  I visited the INE forums a number of times but honestly I didn't go often enough to form a particular view for or against their community, I know that they have some great trainers and from what I hear their material is very good.  I guess if I didn't like what I saw on the OSL I would have investigated their forums more.

The other thing was that was in my mind is the fact that there are very few bootcamps held in Australia - the vendors that appear to get the biggest kudos for their bootcamps are Narbik's, IP Expert (they mention Sydney for bootcamps but never appear to have courses outline) and Internet Expert (highly regarded but don't appear to have courses in Australia).  Of the three, really only Narbik appears to hold bootcamps here and the timing doesn't quite seem convenient to my work life.  The other thing is the expense related to bootcamps, from what I understand Narbik's is very competitively priced and has a teaching style that seems to give nearly a religious mania to his former students, there is the flights/travel/meal expenses that need to be observed.  At present I have elected to use a video based course rather than a bootcamp, being able to replay sections on areas that I need more assistance on and to be able to run at my own pace as well as being significantly less expense seems to be an advantage.  Both IPX and INE have material in this area.

In the end, I put my money down on an IPexpert Bundle (their workbooks Volume 1 and 3 and the Lab prepation videos) and I also have ordered INE's CCIE R&S Audio Bootcamp.

Hopefully the material will arrive in the not too distant future, and I will see how things go.  By the way, at this point in time I'm not endorsing any vendor until I have the material and see what kind of impact it has on my study.  The reality is that I may need to supplement things further and may pick either or another vendor for the supplementary materials even if I'm pleased with the quality/quantity just to get a different way of presenting the same ideas/concepts.