While working IPExpert Volume 1 Workbook Lab 7 which is a frame relay based lab focusing on bridging, I found that when using Dynamips IRB on ethernet interfaces doesn't work as expected when you're using a 3550 as your breakout switch.
This may be related to the one way CDP "feature" due to the 3550 not supporting l2protocol tunnelling on trunk port.
I found it confusing at the time since the bridging was working fine over the frame cloud but not over the ethernet.
This was the irb config I had on R2:
hostname R2
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 route ip
bridge irb
interface Serial2/1.205 point-to-point description to R5 via Frame
frame-relay interface-dlci 205
bridge-group 1
!
interface BVI1frame-relay interface-dlci 205
bridge-group 1
!
ip address 150.100.221.2 255.255.255.0
!
This was the irb config I had on R5:
hostname R5
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 route ip
bridge irb
interface FastEthernet0/1
description to R6 and R7 via Cat3
no ip address
duplex auto
speed auto
bridge-group 1
!
interface Serial2/1.502 point-to-point
no ip address
duplex auto
speed auto
bridge-group 1
!
interface Serial2/1.502 point-to-point
description to R2 via Frame
frame-relay interface-dlci 5012
bridge-group 1
!
interface BVI1frame-relay interface-dlci 5012
bridge-group 1
!
ip address 150.100.221.5 255.255.255.0
!
R6 and R7 are routers with interfaces on directly attached to the 150.100.221.0/24 subnet.
In the end I installed one of the many USB200M Ethernet Adapters I still have before going the breakout switch route in my Ubuntu Server - which was automatically installed as eth2, I edited the lab .net file to have R5 Fa0/1 use eth2, patched it to Cat3 replacing the feed from the breakout switch and fired things up and obtained the expected connectivity.
R2#ping 150.100.221.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.100.221.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/11/36 ms
R2#ping 150.100.221.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.100.221.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/10/24 ms
R2#ping 150.100.221.7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.100.221.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/20 ms
R2#show bridge
Total of 300 station blocks, 297 free
Codes: P - permanent, S - self
Bridge Group 1:
Address Action Interface Age RX count TX count
ca05.06f6.0006 forward Serial2/1.205 0 6 6
ca03.06f6.0006 forward Serial2/1.205 0 5 4
ca04.06f6.0006 forward Serial2/1.205 2 6 5
R2#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 150.100.221.2 - 0000.0c81.46a0 ARPA BVI1
Internet 150.100.221.5 46 ca03.06f6.0006 ARPA BVI1
Internet 150.100.221.6 46 ca04.06f6.0006 ARPA BVI1
Internet 150.100.221.7 25 ca05.06f6.0006 ARPA BVI1
R5#sh bridge
Total of 300 station blocks, 297 free
Codes: P - permanent, S - self
Bridge Group 1:
Address Action Interface Age RX count TX count
ca04.06f6.0006 forward FastEthernet0/1 0 6 5
ca05.06f6.0006 forward FastEthernet0/1 0 6 5
0000.0c81.46a0 forward Serial2/1.502 0 15 15
R5#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 150.100.220.5 - ca03.06f6.0008 ARPA FastEthernet0/0
Internet 150.100.221.2 24 0000.0c81.46a0 ARPA BVI1
Internet 150.100.221.5 - ca03.06f6.0006 ARPA BVI1
Internet 150.100.221.6 45 ca04.06f6.0006 ARPA BVI1
Internet 150.100.221.7 24 ca05.06f6.0006 ARPA BVI1
Not necessarily a show stopper but something to be aware of when you're doing a lab and things appear to be correctly configured but aren't working. It's good to know that I'm not alone with making this observation. There's something certainly to be said for having plenty of interfaces directly attached to your dynamips box and not needing the breakout switch.
Thanks
ReplyDeleteI'm facing the problem with IRB on dynamips.
It's seem bridging works but slow in response and the routers cannot established routing protocol neighbor :(
##################
Visit my HD Movie Collection
http://mega-films.blogspot.com
Thanks!
##################